Show your Company Name instead of your personal email address in invitee event invitation

Featured Answered

Comments

1 comment

  • Official comment
    Avatar
    Tim DaGraca

    Hi @The Dark Zeus,

    Happy to help here, but first I'd love to clarify that with Calendly, there are two types of notifications: Email Confirmations & Calendar invitations.

    1. With Email Confirmations, Calendly sends the invitee an email notification which has a reply-to address that's associated with your Calendly login email. 
    2. With Calendar Invitations, your connected calendar sends the invitee a notification of the booked meeting which has a reply-to address that's associated with your connected calendar.

    It sounds like you may be using Calendar Invitations which is why your email is showing up to the invitee. The solution would be to switch to Email Confirmations and update your email to something generic like, "info@email.com." 

    That way, when your invitee receives a notification, it will be from Calendly (and not your Calendar/email) and have a reply-to email address that's associated with your newly updated login info (the info@email.com, for example.)

    To update your login info, please head to your Account Settings. If you need to switch from Google Single-Sign-On, then please feel free to write a support ticket so that our team can assist.

    Tim DaGraca
    Senior Product Specialist
    The Calendly Team

    Comment actions Permalink

Please sign in to leave a comment.